Mail delivery delay
Incident Report for Crossware Email Signature
Resolved
This incident has been resolved.
Posted May 03, 2024 - 14:46 NZST
Monitoring
A fix has been implemented for all the regions. We are currently monitoring this.
Posted May 03, 2024 - 14:04 NZST
Update
The Canada region has been resolved. We are currently monitoring this.
Posted May 03, 2024 - 13:44 NZST
Identified
Our team has identified an issue with mail delivery, and we are currently implementing a fix for the affected regions.
Posted May 03, 2024 - 13:43 NZST
This incident affected: Processing Engine (Processing Engine - Canada, Processing Engine - France, Processing Engine - US).