Issue: Investigating Service Disruption

Incident Report for Crossware Email Signature

Resolved

Mitigation actions are now complete, and the workaround / fix has been rolled out to affected regions. Email is now routing as expected.
Posted Apr 05, 2026 - 16:51 NZST

Identified

The issue has been diagnosed as an incorrect configured client certificate presented by Microsoft Exchange Online servers. Mitigation action is 
underway to validate a possible workaround.
Posted Apr 05, 2026 - 02:13 NZST

Update

The issue has been diagnosed as an incorrect configured client certificate presented by Microsoft Exchange Online servers. Mitigation action is 
underway to validate a possible workaround.
Posted Apr 05, 2026 - 02:12 NZST

Investigating

Symptoms: Some users may be experiencing unexpected behaviour or degraded performance when using this service.

What We Are Doing: Our team is currently investigating the issue with the highest priority. At this stage, we are still gathering information to determine the root cause.

What You Can Do: No immediate action is required from users at this time. We will provide guidance if any specific steps are needed.
Posted Apr 05, 2026 - 01:04 NZDT
This incident affected: Processing Engine (Processing Engine - Europe, Processing Engine - Qatar K1).