Crossware will close this incident as the issue can now be tracked via Microsoft.
Posted Sep 24, 2025 - 16:15 NZST
Update
Microsoft advised us last week that this issue would be resolved by Friday. However, we are still receiving reports from some customers that the problem persists.
Microsoft has since provided the following update:
- The issue has been narrowed down to how the Exchange server handles the getAttachments and createAttachments API flow, which is causing significant latency. - The impact is regional, not global. Customers in certain forests or geographies are experiencing delays, particularly when loading inline images. - Microsoft has confirmed that their engineering team is actively investigating and treating this with high urgency.
We are continuing to work closely with Microsoft and will share further updates as soon as they become available.
Crossware's Client Side service remains fully operational, but customers in affected regions may still experience delays due to this Microsoft Exchange API issue.
Posted Sep 24, 2025 - 15:25 NZST
Monitoring
Microsoft are currently rolling out a fix for this issue.
This will be released region by region with general release completed on Friday 19th Septmeber 2025.
Please contact Crossware and Microsoft if you are still experiencing the issue after tomorrow.
Posted Sep 18, 2025 - 10:06 NZST
Update
Microsoft are currently conducting a staggered roll out of the fix. This typically begins with 10% on Monday and gradually increases to 100% by Friday, so it will be completed by the end of the day on Friday.
Posted Sep 16, 2025 - 17:04 NZST
Update
Microsoft have confirmed a fix has now been deployed in their test environment and is undergoing final testing. Starting next week, it will begin rolling out to Production pending successful testing.
Posted Sep 11, 2025 - 21:13 NZST
Update
Microsoft have confirmed that a fix has been checked in and are currently waiting for an ETA for it to be deployed to production.
Posted Sep 10, 2025 - 16:45 NZST
Identified
Microsoft's add-in team are colaborating with their Outlook team to address the issue. They are escalating the priority as it is a multi-tenant issue.
Incident number provided by Microsoft: 678890927
Posted Sep 08, 2025 - 09:07 NZST
Investigating
Some customers may be experiencing a pop-up message - “Please wait to send” Inline images are still loading. This is causing a slight delay in the sending of the email but they do successfully send. This is only affecting the New Outlook client. Microsoft are aware of this and we are working with them.